Ok, we need to find out what the culprit is. First we check the status of the tile-cache if there is any:
sudo docker inspect $(sudo docker compose ps -q tile-cache) --format=‘{{.State.ExitCode}} - Status: {{.State.Status}} | Error: {{.State.Error}}’
This shoudl tell us if the config is wrong. It should not be, but you never know. If that returns 0: Status: unhealthy then the healthcheck is propably the problem. It calls this command inside the container:
curl -f -s -o /dev/null -H “X-Reitti-Upstream-Url: https://tiles.dedicatedcode.com/” http://localhost/custom/planet/latest/0/0/0.pbf || exit 1
So, basicly it tries to fetch a tile from tiles.dedicatedcode.com under this url: tiles.dedicatedcode.com/planet/latest/0/0/0.pbf
Hello again! I managed to fix it. Wasn’t all that difficult tbh, but kind of a pain, without knowing why it broke. Turns out, there’s been a change in the docker compose, and the healthcheck i had in mine wasn’t necessary anymore. I think it was checking an old location where the modern tile-server wasn’t putting anything anymore, so the healthtracker though the tileserver was down, even if it wasn’t. Removed it from the docker compose, and voilà. Thanks
danielgraf@discuss.tchncs.de 1 day ago
Yeah, good catch. I didn’t think about that anymore. There was a change while introducing custom map styles to Reitti so they can also be proxied through the cache. That was from 4.0 to 5.0 www.dedicatedcode.com/projects/reitti/…/upgrade/